Skip to Content

LibreOffice の使用

LibreOffice は、Ubuntu 26.04 にプリインストールされている無料のオープンソース オフィス スイートです。機能が豊富で、Microsoft Officeとの互換性も高いです。この記事では、LibreOffice の各コンポーネントの使用方法と実践的なヒントについて説明します。

LibreOffice 概要

LibreOffice には、次のコア コンポーネントが含まれています。

成分関数MS Office 相当
ライターワープロマイクロソフトワード
計算スプレッドシートマイクロソフトエクセル
印象づけるプレゼンテーションマイクロソフトパワーポイント
描くベクターグラフィックスMicrosoft Visio (部分的)
ベースデータベース管理マイクロソフトアクセス
数学数式エディタ数式エディター

インストールとアップデート

Ubuntu 26.04 には、LibreOffice がプリインストールされています。追加の言語サポートをインストールする必要がある場合:

sudo apt install libreoffice libreoffice-l10n-en-us libreoffice-help-en-us

ライター — ワードプロセッサ

Writer は、LibreOffice のワードプロセッサ コンポーネントであり、あらゆる種類のドキュメントの作成に適しています。

基本操作

  • 新しいドキュメント: Ctrl + N
  • ファイルを開く: Ctrl + O、.odt、.docx、.doc、.rtf などをサポート
  • ファイルの保存: Ctrl + S
  • 名前を付けて保存: Ctrl + Shift + S
  • PDF のエクスポート: メニュー「ファイル > PDF としてエクスポート」

フォーマット機能

  • スタイル管理: 「スタイル」サイドバー (F11) を使用して、見出し、本文テキスト、およびリストの形式を一貫して管理します。
  • ページ番号、ヘッダー、フッター: [挿入] メニューから追加します。
  • 目次: 見出しスタイルを適用した後、「挿入 > 目次と索引」を使用して目次を自動生成します。
  • テーブル: 「テーブル > テーブルの挿入」でテーブルを作成します。
  • 画像: ドラッグ アンド ドロップするか、[挿入] > [画像] を使用します。

Writerのキーボードショートカット

ショートカットアクション
Ctrl + B大胆な
Ctrl + Iイタリック
Ctrl + U下線
Ctrl + E中央揃え
Ctrl + J正当化する
Ctrl + Z元に戻す
Ctrl + Yやり直し
F7スペルチェック

Calc — スプレッドシート

Calc は、データ分析とグラフの作成をサポートする、フル機能のスプレッドシート機能を提供します。

基本操作

  • セルを編集: セルをダブルクリックするか、F2 を押して編集モードに入ります。
  • 自動入力: セルを選択し、右下隅の塗りつぶしハンドルをドラッグします。
  • 並べ替え: データ範囲を選択し、「データ > 並べ替え」を使用します。
  • フィルター: 「データ > オートフィルター」を使用します。

共通機能

=SUM(A1:A10) Sum =AVERAGE(A1:A10) Average =COUNT(A1:A10) Count =IF(A1>60,"Pass","Fail") Conditional =VLOOKUP(value,range,col,0) Vertical lookup =SUMIF(criteria_range,criteria,sum_range) Conditional sum =TEXT(A1,"yyyy-mm-dd") Date formatting =CONCATENATE(A1,B1) Text concatenation

グラフの作成

  1. データ範囲を選択してください
  2. 「挿入 > グラフ」をクリックします。
  3. グラフの種類 (棒、折れ線、円など) を選択します。
  4. タイトル、ラベル、スタイルをカスタマイズする
  5. チャートをダブルクリックして編集モードに入ります

ピボットテーブル

  1. データ範囲を選択してください
  2. 「挿入 > ピボットテーブル」をクリックします。
  3. フィールドを行、列、データ領域にドラッグします
  4. 集計方法(合計、個数、平均など)を設定します。

計算のヒント

  • 行/列の固定: 行/列を選択し、「表示 > 行と列の固定」を使用します。
  • 条件付き書式: 値に基づいてセルに色を付けるには、「書式 > 条件付き書式設定」を使用します。
  • データ検証: 「データ > 有効性」を使用してセル入力を制限します
  • 式の監査: 「ツール > 式の監査」を使用して参照と依存を追跡します。

Impress — プレゼンテーション

Impress は、プロフェッショナルなスライドショーを作成するための LibreOffice のプレゼンテーション コンポーネントです。

基本操作

  • 新しいスライド: スライド パネルを右クリック > [新しいスライド]
  • レイアウトの選択: 右側のプロパティ パネルでスライド レイアウトを選択します
  • マスター スライド: [表示] > [マスター スライド] を使用して、すべてのスライドの統一スタイルを編集します。

コンテンツの追加

  • テキスト ボックス: レイアウト内のテキスト領域をクリックするか、[挿入] > [テキスト ボックス] を使用します。
  • 画像: ドラッグ アンド ドロップするか、[挿入] > [画像] を使用します。
  • 図形: 描画ツールバーのさまざまな図形を使用します。
  • 表: 表をスライドに直接挿入します。
  • オーディオ/ビデオ: 「挿入 > オーディオまたはビデオ」でマルチメディアを埋め込みます。

アニメーションとトランジション

  • オブジェクト アニメーション: オブジェクトを選択し、「アニメーション」サイドバーに開始、終了、または強調のアニメーションを追加します。
  • スライド トランジション: [スライド トランジション] パネルでトランジション効果と長さを選択します。

スライドショー再生

ショートカットアクション
F5最初のスライドから開始
Shift + F5現在のスライドから開始
Escスライドショーを終了する
B黒画面で一時停止
W白い画面で一時停止
Page Down次のスライド
Page Up前のスライド

Microsoft Officeとの互換性

MS Officeファイルを開く

LibreOffice は、.docx、.xlsx、.pptx、およびその他の Microsoft Office 形式のファイルを直接開くことができます。ほとんどの場合、書式設定は適切に保持されます。

MS Office形式で保存する

MS Office ユーザーとファイルを交換する必要がある場合:

  1. 「ファイル > 名前を付けて保存」を使用します。
  2. 形式ドロップダウンから対応する MS Office 形式を選択します。
    • ライター: 「Microsoft Word 2007-365 (.docx)」
    • 計算: 「Microsoft Excel 2007-365 (.xlsx)」
    • Impress: 「Microsoft PowerPoint 2007-365 (.pptx)」

デフォルトの保存形式の設定

MS Office 形式で頻繁に保存する必要がある場合:

  1. 「ツール > オプション > 読み込み/保存 > 一般」を開きます。
  2. 「デフォルトのファイル形式とODF設定」で:
    • 文書の種類を「テキスト文書」、形式を「Microsoft Word 2007-365」に設定します。
    • スプレッドシートとプレゼンテーションについても同じことを行います

フォントの互換性

MS Office ドキュメントで一般的に使用されるフォント (Calibri、Times New Roman、Arial など) は Ubuntu では利用できない場合があり、レイアウトがずれる原因となります。解決策:

# Install Microsoft core fonts sudo apt install ttf-mscorefonts-installer # Install Noto fonts for broad coverage sudo apt install fonts-noto fonts-noto-cjk

既知の互換性に関する注意事項

  • 複雑な VBA マクロは完全な互換性がない可能性があります。 LibreOffice は独自のマクロ言語 LibreOffice Basic を使用します
  • 一部の高度なレイアウト効果 (ワードアート、スマートアートなど) は完全に表示されない場合があります
  • 埋め込み OLE オブジェクトは調整が必要な場合があります
  • 重要なファイルを受信するときはフォーマットを確認し、必要に応じて調整することをお勧めします。

LibreOffice パフォーマンスの最適化

スキアのレンダリング

LibreOffice 25.8 は、デフォルトでレンダリングに Skia グラフィック エンジンをすでに使用しています (古い [ハードウェア アクセラレーションを使用する] オプションを置き換えます。以前のバージョンの個別の [メモリ] オプション ページも削除されています)。通常、デフォルトを維持すると、最高のパフォーマンスが得られます。

確認または調整するには、「ツール > オプション > LibreOffice > 表示」の「グラフィック出力」領域に移動します。

  • 「すべてのレンダリングに Skia を使用する」にチェックを入れます
  • サポートされているハードウェアでは、「Force Skia software rendering」のチェックを外したままにして、GPU アクセラレーションを有効にします。表示に不具合が発生した場合は、Skia ソフトウェア レンダリングに切り替えてください。

推奨される拡張機能

「ツール > 拡張機能マネージャー」から追加機能をインストールします。

  • LanguageTool: 多言語をサポートする文法とスペルチェック
  • TexMaths: ドキュメントに LaTeX 数式を挿入する
  • 画像としてエクスポート: プレゼンテーションを画像シーケンスとしてエクスポートします。

まとめ

LibreOffice は、Ubuntu 26.04 で利用できる最もフル機能の無料オフィス スイートです。互換性のあるフォントをインストールし、正しいファイル形式を設定することで、Microsoft Office ユーザーと効果的に共同作業できます。日常のオフィスタスクの大部分については、LibreOffice が十分以上の能力を発揮します。