Skip to Content

LibreOffice 사용

LibreOffice은 Ubuntu 26.04에 사전 설치된 무료 오픈 소스 오피스 제품군입니다. 기능이 풍부하고 Microsoft Office와의 호환성이 뛰어납니다. 이 기사에서는 실용적인 팁과 함께 각 LibreOffice 구성 요소를 사용하는 방법을 다룹니다.

LibreOffice 개요

LibreOffice에는 다음 핵심 구성 요소가 포함되어 있습니다.

요소기능MS 오피스와 동등한
작가워드 프로세싱마이크로소프트 워드
계산스프레드시트마이크로소프트 엑셀
날인프리젠테이션마이크로소프트 파워포인트
그리다벡터 그래픽Microsoft Visio(일부)
베이스데이터베이스 관리마이크로소프트 액세스
수학수학 공식 편집기방정식 편집기

설치 및 업데이트

Ubuntu 26.04에는 LibreOffice가 사전 설치되어 제공됩니다. 추가 언어 지원을 설치해야 하는 경우:

sudo apt install libreoffice libreoffice-l10n-en-us libreoffice-help-en-us

작가 — 워드 프로세싱

Writer는 모든 유형의 문서 작성에 적합한 LibreOffice의 워드 프로세싱 구성 요소입니다.

기본 작업

  • 새 문서: Ctrl + N
  • 파일 열기: Ctrl + O, .odt, .docx, .doc, .rtf 등을 지원합니다.
  • 파일 저장: Ctrl + S
  • 다른 이름으로 저장: Ctrl + Shift + S
  • PDF 내보내기: 메뉴 ‘파일 > PDF로 내보내기’

서식 기능

  • 스타일 관리: “스타일” 사이드바(F11)를 사용하여 제목, 본문 텍스트 및 목록 형식을 일관되게 관리합니다.
  • 페이지 번호, 머리글, 바닥글: ‘삽입’ 메뉴를 통해 추가하세요.
  • 목차: 제목 스타일 적용 후 ‘삽입 > 목차 및 색인’을 통해 목차 자동 생성
  • 테이블: ‘테이블 > 테이블 삽입’을 통해 테이블 ​​생성
  • 이미지: 드래그 앤 드롭하거나 ‘삽입 > 이미지’를 사용하세요.

작성기 키보드 단축키

지름길행동
Ctrl + B용감한
Ctrl + I이탤릭체
Ctrl + U밑줄
Ctrl + E중앙 정렬
Ctrl + J신이 옳다고 하다
Ctrl + Z끄르다
Ctrl + Y다시 하다
F7맞춤법 검사

Calc - 스프레드시트

Calc는 데이터 분석 및 차트 생성을 지원하는 모든 기능을 갖춘 스프레드시트 기능을 제공합니다.

기본 작업

  • 셀 편집: 셀을 두 번 클릭하거나 F2을 눌러 편집 모드로 들어갑니다.
  • 자동 채우기: 셀을 선택하고 오른쪽 하단에 있는 채우기 핸들을 드래그합니다.
  • 정렬: 데이터 범위를 선택하고 “데이터 > 정렬”을 사용하세요.
  • 필터: ‘데이터 > 자동 필터’를 사용하세요.

공통 기능

=SUM(A1:A10) Sum =AVERAGE(A1:A10) Average =COUNT(A1:A10) Count =IF(A1>60,"Pass","Fail") Conditional =VLOOKUP(value,range,col,0) Vertical lookup =SUMIF(criteria_range,criteria,sum_range) Conditional sum =TEXT(A1,"yyyy-mm-dd") Date formatting =CONCATENATE(A1,B1) Text concatenation

차트 만들기

  1. 데이터 범위를 선택하세요
  2. “삽입 > 차트”를 클릭하세요.
  3. 차트 유형(막대, 선, 원형 등)을 선택하세요.
  4. 제목, 라벨, 스타일을 맞춤설정하세요.
  5. 편집 모드로 들어가려면 차트를 두 번 클릭하세요.

피벗 테이블

  1. 데이터 범위를 선택하세요
  2. “삽입> 피벗 테이블”을 클릭하십시오.
  3. 필드를 행, 열 및 데이터 영역으로 드래그
  4. 요약 방법 설정(합계, 개수, 평균 등)

석회질 팁

  • 행/열 고정: 행/열을 선택한 다음 ‘보기 > 행 및 열 고정’을 사용하세요.
  • 조건부 서식: “서식 > 조건부 서식”을 사용하여 값에 따라 셀 색상을 지정합니다.
  • 데이터 유효성 검사: “데이터 > 유효성”을 사용하여 셀 입력을 제한합니다.
  • 수식 감사: “도구 > 수식 감사”를 사용하여 참조 및 종속 항목을 추적합니다.

임프레스 — 프레젠테이션

Impress는 전문적인 슬라이드쇼를 만들기 위한 LibreOffice의 프레젠테이션 구성 요소입니다.

기본 작업

  • 새 슬라이드: 슬라이드 패널을 마우스 오른쪽 버튼으로 클릭하고 ‘새 슬라이드’를 클릭합니다.
  • 레이아웃 선택: 오른쪽 속성 패널에서 슬라이드 레이아웃을 선택합니다.
  • 마스터 슬라이드: ‘보기 > 마스터 슬라이드’를 통해 모든 슬라이드의 통합 스타일을 편집합니다.

콘텐츠 추가

  • 텍스트 상자: 레이아웃에서 텍스트 영역을 클릭하거나 ‘삽입 > 텍스트 상자’를 사용하세요.
  • 이미지: 드래그 앤 드롭하거나 ‘삽입 > 이미지’를 사용하세요.
  • 도형: 그리기 툴바에서 다양한 도형을 사용하세요.
  • 표: 슬라이드에 표를 직접 삽입합니다.
  • 오디오/비디오: ‘삽입 > 오디오 또는 비디오’를 통해 멀티미디어 삽입

애니메이션 및 전환

  • 개체 애니메이션: 개체를 선택하고 ‘애니메이션’ 사이드바에 시작, 종료 또는 강조 애니메이션을 추가합니다.
  • 슬라이드 전환: ‘슬라이드 전환’ 패널에서 전환 효과 및 지속 시간을 선택하세요.

슬라이드쇼 재생

지름길행동
F5첫 번째 슬라이드부터 시작
Shift + F5현재 슬라이드에서 시작
Esc슬라이드쇼 종료
B검은색 화면 일시중지
W흰색 화면 일시중지
Page Down다음 슬라이드
Page Up이전 슬라이드

마이크로소프트 오피스 호환성

MS Office 파일 열기

LibreOffice은 .docx, .xlsx, .pptx 및 기타 Microsoft Office 형식 파일을 직접 열 수 있습니다. 대부분의 경우 서식은 잘 보존됩니다.

MS Office 형식으로 저장

MS Office 사용자와 파일을 교환해야 하는 경우:

  1. “파일 > 다른 이름으로 저장”을 사용하세요.
  2. 형식 드롭다운에서 해당 MS Office 형식을 선택하세요.
    • 작성자: “Microsoft Word 2007-365(.docx)”
    • 계산: “Microsoft Excel 2007-365(.xlsx)”
    • 인상: “Microsoft PowerPoint 2007-365(.pptx)”

기본 저장 형식 설정

MS Office 형식으로 자주 저장해야 하는 경우:

  1. “도구 > 옵션 > 로드/저장 > 일반”을 엽니다.
  2. “기본 파일 형식 및 ODF 설정”에서:
    • 문서 유형을 “텍스트 문서”로 설정하고 형식을 “Microsoft Word 2007-365”로 설정합니다.
    • 스프레드시트와 프리젠테이션에도 동일한 작업을 수행하세요.

글꼴 호환성

MS Office 문서에서 일반적으로 사용되는 글꼴(예: Calibri, Times New Roman, Arial)은 Ubuntu에서 사용하지 못하여 레이아웃이 바뀔 수 있습니다. 솔루션:

# Install Microsoft core fonts sudo apt install ttf-mscorefonts-installer # Install Noto fonts for broad coverage sudo apt install fonts-noto fonts-noto-cjk

알려진 호환성 참고 사항

  • 복잡한 VBA 매크로는 완전히 호환되지 않을 수 있습니다. LibreOffice은 자체 매크로 언어인 LibreOffice Basic을 사용합니다.
  • 일부 고급 레이아웃 효과(예: WordArt, SmartArt)가 완전히 표시되지 않을 수 있습니다.
  • 내장된 OLE 객체는 조정이 필요할 수 있습니다.
  • 중요한 파일을 받을 때 포맷을 확인하고 필요에 따라 조정하는 것이 좋습니다.

LibreOffice 성능 최적화

스키아 렌더링

LibreOffice 25.8은 이미 기본적으로 렌더링에 Skia 그래픽 엔진을 사용합니다(이전의 “하드웨어 가속 사용” 옵션을 대체하고 이전 버전에서 별도의 “메모리” 옵션 페이지도 제거되었습니다). 일반적으로 기본값을 유지하면 최상의 성능을 얻을 수 있습니다.

확인하거나 조정하려면 “도구 > 옵션 > LibreOffice > 보기” 아래의 “그래픽 출력” 영역으로 이동하세요.

  • “모든 렌더링에 Skia 사용”을 선택하십시오.
  • 지원되는 하드웨어에서 GPU 가속을 활성화하려면 “Force Skia 소프트웨어 렌더링”을 선택 해제된 상태로 둡니다. 디스플레이 결함이 보이면 Skia 소프트웨어 렌더링으로 전환하세요.

권장 확장

“도구 > 확장 관리자”를 통해 추가 기능을 설치합니다.

  • LanguageTool: 다국어 지원을 통한 문법 및 철자 검사
  • TexMaths: 문서에 LaTeX 수식 삽입
  • 이미지로 내보내기: 프레젠테이션을 이미지 시퀀스로 내보내기

요약

LibreOffice은 Ubuntu 26.04에서 사용할 수 있는 가장 모든 기능을 갖춘 무료 오피스 제품군입니다. 호환되는 글꼴을 설치하고 올바른 파일 형식을 설정하면 Microsoft Office 사용자와 효과적으로 협업할 수 있습니다. 대부분의 일상적인 사무 작업에 대해 LibreOffice은 그 이상입니다.